SFM Rebuilds Indexes upon Restarting of Windows NT (185722)
The information in this article applies to:
- Microsoft Windows NT Server 4.0 Terminal Server Edition
- Microsoft Windows NT Server 4.0
This article was previously published under Q185722 SYMPTOMS
Services for Macintosh (SFM) on a Windows NT Server computer has had the
ability to rebuild indexes upon startup of the server but if the server
fails to shut down properly, the SFM indexes may not get written and old
directory information may not get updated.
CAUSE
When Windows NT is shut down normally, Services for Macintosh will write
all the volume indexes to the computer hard disk. If the Windows NT Server
computer is shut down improperly, SFM may not have the opportunity to
properly write an index.
RESOLUTION
SFM will now rebuild all indexes upon restart if the server is unable to
close SFM down properly. Installing the latest Hotfix will give SFM the
ability to handle such cases.
To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack
For your convenience, the English version of this post-SP3 hotfix has been
posted to the following Internet location. However, Microsoft recommends
that you install Windows NT 4.0 Service Pack 4 to correct this problem.
STATUSMicrosoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.
Services for Macintosh (SFM) on a Windows NT Server computer has had the
ability to rebuild indexes upon startup of the server but if the server
fails to shut down properly, the SFM indexes may not get written and old
directory information may not get updated. To determine if the index was
rebuilt you can examine event viewer and see if you find event logs with
the 12035 Event ID:
Event ID: 12035
Description: Volume information for <volume name> could not be loaded.
Setting defaults.
Modification Type: | Major | Last Reviewed: | 6/24/2004 |
---|
Keywords: | kbbug kbfix KB185722 |
---|
|