From Field Not Populated by MailSender in Frontpg.ini (185551)



The information in this article applies to:

  • Microsoft FrontPage 98 for Windows

This article was previously published under Q185551

SYMPTOMS

When you use FrontPage 98 Server Extensions to send e-mail from a form, the "From" field in the e-mail message does not contain the address entered in the MailSender line of the Frontpg.ini file.

CAUSE

When you send e-mail with the Microsoft FrontPage 98 Server Extensions, the "From" information of the message is placed in the envelope of the network transaction between the Web server and the SMTP server.

Not all SMTP servers accept the "From" field in this manner. These SMTP servers require the "From" header to be placed in the message data, not in the envelope that surrounds the message. When you use some SMTP servers with FrontPage Server Extensions, the "From" field is left blank or populated with an e-mail address (for example, someone@microsoft.com). Some SMTP servers reject e-mail messages that do not have a "From" header placed in the message data.

Note: This is a known issue for America Online (AOL) e-mail accounts.

RESOLUTION

For information about configuring the Frontpg.ini file to send e-mail from a form, refer to the Server Extensions Resource Kit, located at:

Modification Type:MajorLast Reviewed:12/1/2000
Keywords:kbinfo KB185551