ACC: "File Already in Use" Error When Opening Database on Novell (183936)
The information in this article applies to:
- Microsoft Access for Windows 95 7.0
- Microsoft Access 97
This article was previously published under Q183936 Novice: Requires knowledge of the user interface on single-user computers.
SYMPTOMS
When you try to open a database that is located on a Novell NetWare server,
you may receive the following error message:
Couldn't use <filename>; file already in use.
CAUSE
If a user opens a database and doesn't have Create rights for the folder in
which the database is located, the Microsoft Jet database engine can't
create the locking information file (*.ldb) that is necessary for multiple
users to open the database. Therefore, a user who doesn't have Create
rights opens the database exclusively if a corresponding .ldb file does not
already exist.
RESOLUTION
To prevent this behavior, make sure that all users who open the database
have read, write, create, and delete rights for the folder in which the
database is located.
REFERENCES
For more information about .ldb files, please see the following article in
the Microsoft Knowledge Base:
136128 ACC: Introduction to .ldb Files (95, 97)
Modification Type: | Major | Last Reviewed: | 10/29/2003 |
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Keywords: | kberrmsg kbprb KB183936 |
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