The MTA fails with error 1058 when you try to start it in Exchange Server (182989)



The information in this article applies to:

  • Microsoft Exchange Server 4.0
  • Microsoft Exchange Server 5.0
  • Microsoft Exchange Server 5.5
  • Microsoft Exchange 2000 Server
  • Microsoft Small Business Server 2000

This article was previously published under Q182989

SYMPTOMS

When you try to start the message transfer agent (MTA) from Control Panel / Services, you may receive the following error message:
Could not start the Microsoft Message Transfer Agent service on <servername>.
Error 1058: The specified service is disabled and cannot be started.
You may receive this error starting any service, including the Simple Mail Transfer Protocol(SMTP) service or any Microsoft Exchange service.

If Exchange Server is running on a Microsoft Windows cluster, the Microsoft Exchange MTA Stacks resource will not start. The Cluster log will display the following error message:
ERR Microsoft Exchange Message Transfer Agent <Exchange Message Transfer Agent Instance (NSWMAIL)>:
[EXRES] DwStartService: failed to start service 'MSExchangeMTS'. Error 1058.

CAUSE

This behavior can occur if the service is disabled within the current hardware profile.

RESOLUTION

To resolve this behavior, follow these steps:
  1. Click Start, point to Settings, click Control Panel, and then double-click the Services icon.
  2. Select the Microsoft Exchange Message Transfer Agent service, and then click Hardware Profiles.
  3. Click the current hardware profile, click Enable, and then click OK.
  4. Ensure that the Startup Type for the service is set to Manual or Automatic.
  5. Click Start to start the service.
The Hardware Profile Setting is designed to assist computers that have multiple configurations. Third-party applications often disable this service to ensure that these services do not disrupt their product. To check and correct Hardware Profile behaviors:
  1. Click Start, point to Settings, click Control Panel, and then double-click the Services icon.
  2. Click the service that is not responding, and then click Hardware Profiles.
  3. Verify that the setting for the original configuration is enabled. If the setting for the original configuration is not enabled, double-click to change the setting.
NOTE: This behavior can occur for any service listed under Services in Control Panel.

MORE INFORMATION

For more information about other causes of error 1058, click the following article number to view the article in the Microsoft Knowledge Base:

181835 Unable to start the server service


Modification Type:MinorLast Reviewed:5/9/2005
Keywords:kberrmsg kbprb kbusage KB182989