StartDoc and OpenPrinter Fail to Return Correct Error Codes (182714)



The information in this article applies to:

  • Microsoft SNA Server 3.0
  • Microsoft SNA Server 3.0 SP1
  • Microsoft SNA Server 3.0 SP2
  • Microsoft SNA Server 4.0

This article was previously published under Q182714

SYMPTOMS

When you trace the SNAPRINT service, StartDoc and OpenPrinter API calls may fail to report the correct error codes in the traces.

CAUSE

Additional trace statements are invalidating the GetLastError call.

RESOLUTION

SNA Server 3.0

To resolve this problem, obtain the latest service pack for SNA Server version 3.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

184307 How to Obtain the Latest SNA Server Version 3.0 Service Pack


SNA Server 4.0

This problem was corrected in the latest SNA Server version 4.0 U.S. Service Pack. For information on obtaining this Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

S E R V P A C K

STATUS

Microsoft has confirmed that this is a problem in SNA Server 3.0 and 4.0. This problem was first corrected in SNA Server 3.0 Service Pack 4.

Modification Type:MinorLast Reviewed:9/22/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix KB182714 kbAudDeveloper