Cannot Log On to Web Server Requiring Authentication with New Realm (182133)



The information in this article applies to:

  • Microsoft Internet Explorer 4.01 for Windows NT 4.0
  • Microsoft Internet Explorer 4.01 for Windows 95

This article was previously published under Q182133

SYMPTOMS

When you use Internet Explorer to connect to a Web server requiring authentication, you may not be able to log on to the server properly if the response from the Web server includes a realm change.

CAUSE

When you log on to a Web server requiring a user name, password, and realm, the Web server may send a realm change back to your browser. The browser should then authenticate on the new server with the same user name and password, and the new realm. If the browser does not send the new realm with the authentication information, you may not be able to log on to the Web server.

RESOLUTION

This issue is resolved by the following updated files:

For Windows NT 4.0:

Wininet.dll, dated 12-15-97, 367,888 bytes, version 4.71.2215.0 or later

For Windows 95:

Wininet.dll, dated 12-15-97, 368,400 bytes, version 4.71.2215.0 or later


STATUS

Microsoft has confirmed this to be a problem in Microsoft Internet Explorer 4.01 for Windows 95 and NT 4.0. An update to address this problem is now available, but is not fully regression tested and should be applied only to computers experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft does not recommend implementing this update at this time. Contact Microsoft Technical Support for additional information about the availability of this update.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbenv kbprb KB182133