FP: Database Error: [Microsoft][ODBC Microsoft Access 97 Driver] Couldn't Find File '(Unknown)' When You Preview Database Region Page (181982)



The information in this article applies to:

  • Microsoft FrontPage 2000
  • Microsoft FrontPage 98 for Windows

This article was previously published under Q181982

SYMPTOMS

When you preview a page in a Web Browser that contains a database region, you may receive the following error message:
Database Error: [Microsoft][ODBC Microsoft Access 97 Driver] Couldn't find file '(unknown)'.

CAUSE

This error message appears when the Microsoft Access database file specified in the Data Source Name (DSN) properties cannot be found. This most often occurs if the database file has been moved or deleted.

RESOLUTION

To resolve this behavior, configure the system DSN by following these steps:
  1. On the Windows Start menu, point to Settings, and click Control Panel.
  2. Double-click the 32-Bit ODBC icon (Windows 95) or the ODBC icon (Windows NT).
  3. Click the System DSN tab.
  4. In the System Data Sources list, click the DSN name you want to configure, and click Configure.
  5. Click Select.
  6. Select your database file and click OK.
  7. Click OK two more times.

MORE INFORMATION

For additional information, please see the following articles in the Microsoft Knowledge Base:

175770 FP98: How to Post Information to a Database Using ASP

175771 FP98: How to Display Contents of a Database Using ASP

182122 FP98: How to Remove or Customize the "No Records Returned" Message


Modification Type:MajorLast Reviewed:12/1/2000
Keywords:kbprb KB181982