XCLN: Error Msg: Application Error, Call to Undefined Dynalink (179802)



The information in this article applies to:

  • Microsoft Exchange Client 4.0
  • Microsoft Exchange Client 5.0
  • Microsoft Outlook, Exchange Server Edition

This article was previously published under Q179802

SYMPTOMS

When you try to start the Windows 3.x Exchange or Outlook client, you may receive one of the following error messages:
Application Error
Call to Undefined Dynalink
-or-
Application Error
Cannot find Mapi.dll

CAUSE

The Mapi.dll file, located in the c:\windows\system subdirectory by default, is missing, corrupted, or has been replaced by another version.

WORKAROUND

To correct the problem, perform one of the following steps:
  • Copy the Mapi.dll from another Windows 3.x client system that is working properly.

    -or-
  • Reinstall the Exchange client.

    -or-
  • Expand Mapi.dll from the client CD-ROM cabinet (.Cab) files.

    The syntax for the EXPAND (Expand.exe) utility is:
    EXPAND <sourcename> <destinationname>

Modification Type:MinorLast Reviewed:8/18/2005
Keywords:kbprb kbusage KB179802