PUB: Can't Create Temp File if Permissions Wrong on Root Folder (179085)



The information in this article applies to:

  • Microsoft Publisher for Windows 3.0

This article was previously published under Q179085

SYMPTOMS

When you attempt to save a Microsoft Publisher file to a Novell NetWare 4.11 file server, you may receive the following message even though you have Create, Write, and/or Modify permissions for the folder where you are trying to save the file:
Publisher cannot create a temporary working file
When you close the message box, the file IS saved to the server.

CAUSE

When you try to save an existing publication, Publisher attempts to create a temporary file in the root folder of the destination drive. If you are using Novell's Client32 version 4.2 or earlier, you will experience this problem regardless of what OS you are using. Using Microsoft's "Client for NetWare Networks" client will not produce this problem. This error only happens when you edit an existing publisher document and try to save it. When you create a new document and save it, it will work fine.

For example, if you have a Novell NetWare 4.11 server with the following configuration
   Server Name: SRV1
   Disk Volume: Vol1, mapped as N: on a Windows NT, Windows 95, or Windows
                98 computer.
   Client     : Novell Client32 version 4.2 or earlier.
   Folder where files are being saved: Test.pub (already existing)
				
then, open the file Test.pub and attempt to save the file to N:\<Directory Path>\Test.pub, you will receive the error message described in the "Symptoms" section, even though the file will be saved correctly. However, if you change the client to be Microsoft's "Client for Netware Networks" client and open the file Test.pub and attempt to save the file to N:\<Directory Path>\Test.pub, you will not receive the error.

WORKAROUND

To work around this behavior, use one of the following methods:

Method 1: Use the Microsoft's "Client for Netware Networks"

Change the client you are using from Novell Client (Client32) version 2.5 and earlier to use Microsoft's "Client for Netware Networks". Once the client has been changed, you should be able to create the necessary temp file without having to give full rights to the root directory. This has been tested with a Novell NetWare 4.11 server using Microsoft's "Client for Netware Networks" In Windows 95 and 98.

Method 2: Modify Your Rights on the Server

Change the permissions for the root folder that contains the folder where you want to save your file. You should have the following permissions for the root folder:

Read
File Scan
Erase
Create

Once the appropriate permissions have been set, Publisher will be able to create the temporary file on the server and you will not receive the error message.

Method 3: Ignore the Message

You can ignore (close) the message even though Publisher is not able to create the temporary file because it will save the publication in the correct location.

Method 4: Save the Publication to a Local Disk Drive First

Save the file to a local disk drive and then copy it to the folder on the server. By using this method, you will avoid the error message because Publisher does not need to create a temporary file on the server.

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article.

MORE INFORMATION

The error described in the "Symptoms" section occurs when you do not have Create permission for the root folder (for example, N:\) of the server.

If you have Create permissions for the root folder, but you do not have erase permissions, you will receive the following message instead of the one described in the "Symptoms" section:
Publisher cannot write to <drive letter>:\<path to save directory> on the disk.

Your hard disk may be full, or you may have hardware problems. Please exit Publisher, check to make sure your hard disk is not full, check for hardware problems, and try again. For more information on possible solutions, press F1 now.

Modification Type:MinorLast Reviewed:8/17/2005
Keywords:kbnetwork kbprb KB179085