SNA Server May Fail to Log Event 624 and Create Snadump.log (178255)



The information in this article applies to:

  • Microsoft SNA Server 3.0
  • Microsoft SNA Server 3.0 SP1
  • Microsoft SNA Server 3.0 SP2

This article was previously published under Q178255

SYMPTOMS

When SNA Server or an SNA application ends abnormally due to an access violation or internal breakpoint, SNA Server normally logs an Event 624 and produces an Snadump.log file in the <snaroot>\traces directory, to assist support personnel in diagnosing problems. In some cases, SNA Server fails to log an Event 624 and produce an Snadump.log file.

CAUSE

In some cases, the SNA Server exception handling code was failing to produce an <snaroot>\traces\snadump.log following an access violation or unhandled exception in an SNA Server module.

STATUS

Microsoft has confirmed this to be a problem in SNA Server 3.0 (including SP1 and SP2).

This problem was corrected in the latest SNA Server version 3.0 U.S. Service Pack. For information on obtaining this Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

S E R V P A C K


Modification Type:MinorLast Reviewed:9/22/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix KB178255