Perfmon Degrades SNA Server When Many 3270 LUs in Use (174644)
The information in this article applies to:
- Microsoft SNA Server 2.11 SP1
- Microsoft SNA Server 2.11 SP2
- Microsoft SNA Server for Windows NT 4.0
This article was previously published under Q174644 SYMPTOMS
When you use Windows NT Performance Monitor to monitor any SNA performance
objects every second, SNA Server performance degrades significantly when
150 users or more have an active 3270 session. Users with active 3270
sessions receive host response delays from 20 seconds to two minutes.
CAUSE
When you monitor SNA Server performance objects, SNA Server reports
response time monitor (RTM) performance data on every active 3270 LU.
When a large number of 3270 LUs are in use, this reporting can degrade
3270 performance for current 3270 users if a small Performance Monitor
reporting interval is chosen (such as the default one-second reporting
interval in Windows NT Performance Monitor).
RESOLUTION
To prevent the problem from occurring with SNA Server 2.11 or 3.0,
follow these steps:
- Choose an infrequent Performance Monitor reporting interval, such as
one minute or more, rather than the default of one second.
- Do not continuously monitor SNA Server performance objects during
production use
STATUS
Microsoft has confirmed this behavior with SNA Server versions 2.11,
3.0, and 4.0 and is investigating how to address this issue in future
releases.
This problem was corrected in the latest SNA Server version 4.0 U.S.
Service Pack. For information on obtaining this Service Pack, query on
the following word in the Microsoft Knowledge Base (without the spaces):
The updated SNA Server 4.0 modules are:
<snaroot>\system\snaservr.exe
<snaroot>\system\trcservr.exe
<snaroot>\system\snaperf.dll
Modification Type: | Minor | Last Reviewed: | 9/22/2005 |
---|
Keywords: | kbHotfixServer kbQFE kbbug kbfix kbnetwork KB174644 |
---|
|