FP: Socket Code 13101 Error Opening, Creating New Web (171675)



The information in this article applies to:

  • Microsoft FrontPage 97 for Windows with Bonus Pack
  • Microsoft FrontPage for the Macintosh 1.0
  • Microsoft Visual InterDev 1.0
  • Microsoft Visual InterDev 6.0

This article was previously published under Q171675

For a Microsoft FrontPage 98 version of this article, see 194449.

SYMPTOMS

In FrontPage Explorer, when you open or create a new Web using Secure Sockets Layer (SSL) you receive one of the following error messages
There is no server on port 443 at 'server name'. You have selected the option 'Connect Using SSL'. This connection problem may indicate that the server does not support Secure Socket Layer (SSL) communications, or that it uses SSL communications on a different port number.

-or-

Unable to connect to server at 'xxx.xxx.xxx.xxx' on port 443 (socket code 13101).
where xxx.xxx.xxx.xxx represents the host name or Internet Protocol (IP) address of your FrontPage Web.

CAUSE

SSL connections require a security certificate. Socket code 13101 is generated when the security certificate is not from a recognized certificate authority or when it is from a recognized certificate authority but it cannot be read by FrontPage.

RESOLUTION

Method 1: Obtain a Certificate from a Recognized Authority

FrontPage 97 only recognizes certificates signed by the following certificate authorities:
   Verisign-Secure Server Certification Authority
   RSA Data Secirity, Inc.
   AT&T-Certificate Services
   AT&T-Directory Services
				
If your certificate is from a recognized authority, its public key may not start with a "1" bit. In this case, contact the authority to request a new certificate with a public key that has its high bit set to "1."

Method 2: Upgrade to FrontPage 98

FrontPage 98 can correctly read public keys that begin with values other than 1 if they are from a recognized certificate authority.

NOTE: Neither FrontPage 97 nor FrontPage 98 support 128-bit encryption.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

SSL is a World Wide Web feature that supports data encryption and server authentication. All data sent to or from the client using SSL is encrypted.

You can obtain digital certificates from Verisign or AT&T. For additional information, please visit either of the following Web sites: For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

142748 Obtaining a Secure Sockets Layer (PCT/SSL) Digital Certificate

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

For information about how to contact the third-party vendors listed in this article, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z


Modification Type:MajorLast Reviewed:3/1/2006
Keywords:kbbug kberrmsg kbExtension kbfix kbServer kbusage KB171675 kbAudDeveloper