Garbled Text in List Boxes and Drop-Down List Boxes (171157)



The information in this article applies to:

  • Microsoft Internet Explorer 1.0 for Windows 95
  • Microsoft Internet Explorer 2.0 for Windows 95
  • Microsoft Internet Explorer 3.0 for Windows 95
  • Microsoft Internet Explorer 3.01 for Windows 95
  • Microsoft Internet Explorer 3.02 for Windows 95
  • Microsoft Internet Explorer 4.0 for Windows 95
  • Microsoft Internet Explorer 4.01 for Windows 95
  • Microsoft Internet Explorer 5.0 for Windows 95
  • Microsoft Internet Explorer 5.01 for Windows 95
  • Microsoft Internet Explorer 5.5 for Windows 95
  • Microsoft Internet Explorer 3.x for Windows 95
  • Microsoft Internet Explorer 4.x for Windows 95
  • Microsoft Internet Explorer 2.0 for Windows NT 4.0
  • Microsoft Internet Explorer 3.0 for Windows NT 4.0
  • Microsoft Internet Explorer 3.01 for Windows NT 4.0
  • Microsoft Internet Explorer 3.02 for Windows NT 4.0
  • Microsoft Internet Explorer 4.0 for Windows NT 4.0
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0
  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 5.01 for Windows NT 4.0
  • Microsoft Internet Explorer 5.5 for Windows NT 4.0

This article was previously published under Q171157

SYMPTOMS

When you view a Web page using Internet Explorer with multilanguage support enabled, the text within list boxes or drop-down list boxes may appear garbled or unintelligible.

CAUSE

This behavior can occur if you are viewing a Web page that contains Double-Byte Character Set (DBCS) characters, such as Chinese or Japanese. The Windows system font, which is used within list boxes and drop-down list boxes, is not capable of displaying DBCS characters.

RESOLUTION

To resolve this issue, install the appropriate localized (foreign language) version of Windows 95 or Windows NT. Doing so installs a system font that is capable of displaying DBCS characters.

Modification Type:MajorLast Reviewed:12/5/2003
Keywords:kbenv kbui KB171157