Backup Exec Stops Windows NT RPC Service (170582)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0

This article was previously published under Q170582

SYMPTOMS

You may see the error message:
The RPC server is too busy to complete this operation.
Other symptoms include poor performance, inability to open Control Panel, and inability to open the Services icon in Control Panel. Clicking My Computer takes a long time to enumerate network resources.

CAUSE

Backup Exec version 6.11 Rev. 184 installs an RPC service that conflicts with the standard Windows NT RPC service.

RESOLUTION

WARNING: Using Registry Editor incorrectly can cause serious, system-wide problems that may require you to reinstall Windows NT to correct them. Microsoft cannot guarantee that any problems resulting from the use of Registry Editor can be solved. Use this tool at your own risk.

To resolve this problem, use one of the following methods:
  • Disable the Backup Exec RPC service by performing the following steps:

    1. Run Registry Editor (Regedt32.exe).
    2. Go to the following registry key:
               HKEY_LOCAL_MACHINE\System\CurentControlSet\Services
                \ArcadaRPCInterfacesService
      							
    3. Change the Start value to 0x4 (hexadecimal).
  • Upgrade to Backup Exec version 6.11 Rev. 112. Please contact Seagate for more information.

  • By booting to a DOS diskette or through a parallel installation, rename backupexec\nt\bediag.exe to ~bediag.exe.

MORE INFORMATION

Backup Exec is a third-party product manufactured by Seagate, Inc., a vendor independent of Microsoft; Microsoft makes no warranty, implied or otherwise, regarding this product's performance or reliability.

Modification Type:MajorLast Reviewed:6/3/2003
Keywords:kb3rdparty KB170582