Memory Leak in SERVICES.EXE Causes Performance Degradation (170509)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0

This article was previously published under Q170509

SYMPTOMS

Over time, the Windows NT system responsiveness appears sluggish, and clients may report a gradual decrease in system performance.

By tracking the amount of Private Bytes for Services.exe, it can be observed that over time it increases without decreasing. This is viewable using Windows NT Performance Monitor by choosing the following counter to monitor:
   Object: Process
   Instance: SERVICES
   Counter: Private Bytes
				

CAUSE

During client authentication on Windows NT servers (non-Domain Controllers), a lookup of the current Windows NT domain name is performed. A pointer to the Windows NT domain name is saved in a global location without freeing the previous Windows NT domain name that is already stored there.

This memory leak problem can effect Microsoft Exchange and Microsoft SNA Server when running on a Windows NT server. Each time an Exchange or SNA Server client connects to the server over sockets, a small memory leak occurs on the server. This eventually causes performance degradation and requires a reboot to recover.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

152734 How to Obtain the Latest Windows NT 4.0 Service Pack


STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.

Microsoft has confirmed this to be a problem in Windows NT version 3.51. A supported fix is now available, but has not been fully regression-tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbbug kbenv kbfile kbfix KB170509