PRB: NTLM Authentication Fails in Windows 95 If Not Logged On (165895)



The information in this article applies to:

  • Microsoft Visual InterDev 1.0

This article was previously published under Q165895

SYMPTOMS

If you are using Windows 95 and do not log on to the local machine, you will not able to open or create projects when the Web Server is using NTLM Authentication. Instead, you will receive a warning message:
"Unable to open web '': NTLM Authentication failed (code - 2146893042).

CAUSE

The NTLM authentication system queries the client machine to provide the currently logged-on user's name and password. If the client machine has a trust relationship with the server, then the client will provide this information. When a Windows 95 user does not log on the machine, this trust relationship is not established and the NTLM authentication results in a warning message and the operation fails.

RESOLUTION

In order to connect to any Web server using the NTLM authentication protocol, a Windows 95 user must log in to the client machine.

MORE INFORMATION

Steps to Reproduce Behavior

  1. On the server machine, turn on NTLM authentication in the Internet\ Service manager.
  2. On the client machine, click "Cancel" on the logon screen to bypass the logon.
  3. Open Visual InterDev 1.0 and attempt to create or open a Web project.

REFERENCES

For the latest Knowledge Base articles and other support information on Visual InterDev and Active Server Pages, see the following page on the Microsoft Technical Support site:

Modification Type:MajorLast Reviewed:5/2/2006
Keywords:kbExtension kbprb kbServer kbWebServer KB165895