TN3270 Clients Cannot Connect to the TN3270 Server (165845)



The information in this article applies to:

  • Microsoft SNA Server 3.0, when used with:
    • the operating system: Microsoft Windows NT

This article was previously published under Q165845

SYMPTOMS

TN3270 clients are unable to connect to the TN3270 Server until the TN3270 Server is restarted. When TN3270 clients are unable to connect, a network monitor trace shows that the server sends TCP/IP resets to TN3270 client connection requests.

CAUSE

There was a critical section deadlock in the TN3270 Server licensing code when a TN3270 client attempts to connect to the TN3270 Server at the same time that a TN3270 client disconnects.

RESOLUTION

The TN3270 Server service has been updated to correct this problem. To resolve this problem, obtain the hotfix mentioned below.

STATUS

Microsoft has confirmed this to be a problem in SNA Server version 3.0. This problem was corrected in the latest Microsoft SNA Server 3.0 U.S. Service Pack. For information on obtaining the service pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

S E R V P A C K


Modification Type:MajorLast Reviewed:11/21/2003
Keywords:kbbug kbfix kbnetwork KB165845