Change Permissions Needed on Index Server System Files (165340)



The information in this article applies to:

  • Microsoft Index Server 1.1
  • Microsoft Index Server 2.0

This article was previously published under Q165340

SYMPTOMS

When you use Microsoft Index Server, you may get the following error message in your browser after it authenticates the query page:
Error: Access is denied.

CAUSE

Even if you have rights to the three files needed to make the query (*.htm, *.idq, and *.htx), the files still may not be authenticated. Microsoft Windows NT NTFS file restrictions on the files used may cause a problem for the search engine under the %systemroot%\system32 directory.

WORKAROUND

Do one of the following:
  • Make sure you have Change permissions to the %systemroot%\system32 directory.

    -or-
  • Make sure you have Change permissions to the following files:
          Idq.dll
          Query.dll
          Iinfoadmn.dll
          Imagehlp.dll
          Qperf.dll
    
    						

Modification Type:MajorLast Reviewed:9/30/2003
Keywords:kbprb KB165340