Service Pack 2 May Cause Loss of Connectivity in Remote Access (161368)
The information in this article applies to:
- Microsoft Windows NT Server 4.0 SP2
- Microsoft Windows NT Workstation 4.0 SP2
This article was previously published under Q161368 SYMPTOMS
After you install Service Pack 2 for Windows NT 4.0, you may not be able
to ping or otherwise make use of the connection you have established with
an ISP when using RAS to dial out.
Additionally, the route table may not have a route for the remote
connection.
CAUSE
The Multilinking Protocol (MP) option is always negotiated during the Link
Control Protocol (LCP)-phase of negotiation in Service Pack 2 for Windows
NT 4.0. This occurs if the Enable PPP LCP Extensions check box on the
Server tab of the Edit Phonebook Entry dialog box is enabled or disabled.
Although MP is an extension of LCP, it is not part of RFC 1570 -- LCP
Extensions. In Service Pack 2 for Windows NT 4.0, it is no longer
necessary to enable this check box to attempt MP negotiation.
NOTE: Some Internet service providers (ISP) cannot deal with the MP
options correctly. This problem is resolved by changing the conditions in
which RAS sends multilink information to the remote server.
RESOLUTION
The binaries below resolve this issue by making an attempt at MP
negotiation only if there is more than one link in the phonebook entry.
STATUS
Microsoft has confirmed this to be a problem in Microsoft Windows NT
version 4.0. This problem was corrected in the latest Microsoft Windows NT
4.0 U.S. Service Pack. For information on obtaining the service pack,
query on the following word in the Microsoft Knowledge Base (without the
spaces):
NOTE: This fix is to be applied only to computers with Service Pack 2 for
Windows NT 4.0 installed.
This hotfix has been posted to the following Internet location:
Modification Type: | Major | Last Reviewed: | 5/13/2003 |
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Keywords: | kbbug kbenv KB161368 |
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