Errors in HyperTerminal with No Service Provider Installed (160890)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Workstation 4.0

This article was previously published under Q160890

SYMPTOMS

When you start HyperTerminal from the Start menu, Windows NT may respond in any of the following ways:
  • The first time you start HyperTerminal you may see several different screens prompting you for your area code and other information about features such as call waiting and numbers required to dial outside lines.
  • You may be prompted with a Connect To screen.
  • You may receive the following message:
          You need to install a modem before you can make connection. Would
          you like to do this now?
    						

    Clicking Yes starts the Install New Modem Wizard, even though a modem is already installed.

CAUSE

These behaviors can occur when there are no TAPI service providers installed.

RESOLUTION

To install a service provider, follow these steps:
  1. In Control Panel, double-click Telephony.
  2. Click the Telephony Drivers tab.
  3. Click Add.
  4. Click Unimodem Service Provider, and then click Add.
  5. Click Close.
The Telephony Drivers tab should now display the following installed telephony drivers:
  • TAPI Kernel-Mode Service Provider
  • Unimodem Service Provider

MORE INFORMATION

HyperTerminal uses TAPI to obtain a list of available modems. If there are no TAPI service providers installed, no modems are returned by TAPI. If there are no available modems, the Install New Modem Wizard is started.

Modification Type:MajorLast Reviewed:8/9/2001
Keywords:KB160890