XFOR: The Chat Log File Is Locked At All Times (160860)
The information in this article applies to:
- Microsoft Commercial Internet System 1.0
This article was previously published under Q160860 SYMPTOMS
When you try to rename the log file created by the Chat logging service,
the following error message appears:
The process cannot access the file because it is being used by another
process.
The persistent channel that I created has the "autostart" flag enabled.
CAUSE
Once the logging service is started, the file is locked. The Chattran.asp,
which is the Chat transcript executed from the Internet Explorer, causes
the lock as well.
WORKAROUND
There are several ways to work around this problem:
- Instead of renaming the file, you may be able to use the copy
command.
- Disable the "autostart" flag; this allows you to rename the file. This
workaround works only if the channel is empty.
- Use the CHATCMD command "KILLCHANNEL."
- Restart the server and rename the file before starting the logging
service.
Please note the logging service is a sample program; it provides a simple
service to demonstrate the Chat server capability.
Modification Type: | Major | Last Reviewed: | 9/30/2003 |
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Keywords: | KB160860 |
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