You receive an error message when you run the Autochk.exe utility on a partition after you restart the computer or when you schedule the Chkdsk.exe utility to run on a partition on a Windows 2000-based computer or a Windows NT-based computer (160654)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0

This article was previously published under Q160654

SYMPTOMS

On a Microsoft Windows 2000-based computer or a Microsoft Windows NT-based computer, when you run the Autochk.exe utility on a partition after you restart the computer or when you schedule the Chkdsk.exe utility to run on a partition, the utility is run on the partition and you receive one of the following error messages.

Message 1
Cannot lock volume for direct access
Message 2
Cannot open volume for direct access

CAUSE

This problem occurs because the Chkdsk.exe utility or the Autochk.exe utility could not lock the partition. This problem can occur if another utility or service, such as a virus checker program or a disk monitoring program, locks the partition before you try to run the Chkdsk.exe utility or the Autochk.exe utility.

RESOLUTION

Windows 2000

To resolve this problem on a Windows 2000-based computer, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Administrative Tools, double-click Services, and then change the Start Type of the other third-party utility to Manual.

Windows NT

To resolve this problem on a Windows NT-based computer, follow these steps:
  1. Click Start, point to Settings, click Control Panel, and then double-click Devices.
  2. Look for third-party devices that are set to run at startup that might be locking the drive. If you locate any, double-click the third-party device, and then set its startup type to Disabled.

    Note If you are not sure whether to disable the device, create a test hardware profile, and then disable the device in the test hardware. If this does not work, revert to your original profile. To create a test hardware profile, follow these steps:
    1. Click Start, point to Settings, click Control Panel, and then double-click System.
    2. Click the Hardware Profiles tab, click Original Configuration, click Copy, and then name the profile Test.
    You can now disable devices or services in the test hardware profile. To do this, follow these steps:
    1. Click Start, point to Settings, click Control Panel, and then double-click Services or Devices.
    2. Click the service or device that you want to disable, click Hardware Profile, click Test, and then click Disable.

Modification Type:MajorLast Reviewed:1/27/2006
Keywords:kbHardware kbprb KB160654