NetBIOS Applications Stop Receiving Data Running on TCP/IP 32 (156441)



The information in this article applies to:

  • Microsoft TCP/IP-32 for Windows for Workgroups 3.11
  • Microsoft TCP/IP-32 for Windows for Workgroups 3.11a
  • Microsoft TCP/IP-32 for Windows for Workgroups 3.11b

This article was previously published under Q156441

SYMPTOMS

NetBIOS applications running on Microsoft TCP/IP 32 for Windows For Workgroups may stop receiving data from server-side applications. The problem will only occur if the client pauses before receiving data for more than one NetBIOS Session KeepAlive interval.

NOTE: The default NetBIOS Session KeepAlive interval for TCP/IP 32 is 60 minutes.

CAUSE

The problem occurs because of the NetBIOS over TCP/IP Vxd's (VNBT) handling of Session KeepAlive packets when application data is also pending in TCP. If VNBT posts a receive for application data pending in TCP and a NetBIOS Session KeepAlive packet also resides in the TCP pending queue, VNBT would incorrectly determine the state of the lower TCP connection resulting in all future NetBIOS Receives being placed in a pending state.

RESOLUTION

Vnbt.386 was modified to correctly handle NetBIOS KeepAlive packets in TCP's pending queue.

STATUS

Microsoft has confirmed this to be a problem in TCP/IP 32 version 3.11B. A supported fix is now available, but is not fully regression tested and should be applied only to systems experiencing this specific problem. Contact Microsoft Product Support Services for more information.

Modification Type:MajorLast Reviewed:9/30/2003
Keywords:kbbug KB156441