Print Manager Hangs If Printer Description Has Multiple Commas (154027)



The information in this article applies to:

  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0

This article was previously published under Q154027

SYMPTOMS

Under Windows NT 3.51, Print Manager stops responding when you attempt to connect to a shared network printer. This problem occurs when Print Manager is building a browse list of available printers in your workgroup or domain.

Under Windows NT 4.0, the Add Printer wizard stops responding when you attempt to perform the same operation as above.

CAUSE

One or more of the shared printers in the workgroup or domain has a comment or description that contains multiple comma characters in succession, such as "Finance printer,,High Quality,2nd Floor".

RESOLUTION

Edit the printer description or comment to remove the multiple, successive commas.

STATUS

Microsoft has confirmed this to be a problem in Windows NT versions 3.51 and 4.0. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

Modification Type:MajorLast Reviewed:8/9/2001
Keywords:kbnetwork KB154027