Cannot Perform a NET VIEW Across RAS to Windows 95 Client (150059)



The information in this article applies to:

  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows 95

This article was previously published under Q150059

SYMPTOMS

Windows NT servers and workstations are unable to perform a NET VIEW on a Windows 95 client when they are dialed in remotely through Remote Access Service (RAS). The Windows NT clients can perform a NET USE without difficulty, but they must know the share connection. The Windows 95 remote can perform a NET VIEW or NET USE to Windows NT servers and workstations or other Windows 95 clients without difficulty.

The following error message appears in Windows NT when a NET VIEW is performed from a command prompt:
System error 1450 has occurred.
Insufficient system resources exist to complete the requested service.

CAUSE

Windows 95 allows only one server message block (SMB) request at a time from each client. The Windows NT redirector has code that prevents all the command slots at a server from being tied up with "long term" operations. Remote API requests are marked as long term requests.

STATUS

Microsoft has confirmed this to be a problem in Windows NT versions 3.5 and 3.51. This problem was corrected in the latest Windows NT 3.51 U.S. Service Pack. For information on obtaining the Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

S E R V P A C K


Modification Type:MajorLast Reviewed:12/16/2003
Keywords:kbnetwork KB150059