PPP.LOG File Not Created Or Has File Size of 0 (136813)



The information in this article applies to:

  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0

This article was previously published under Q136813

SYMPTOMS

After you use Registry Editor to configure Remote Access Services (RAS) to use a PPP.LOG file, the file may not be created or, the file size may be displayed as zero bytes, even though the file contains information about the previous RAS PPP connection.

CAUSE

RAS uses the PPP.LOG file to log information about PPP connections between a Windows NT RAS client or server and a remote PPP client or server.

If you enable the PPP.LOG file, you restart both the RAS server service and the RAS client before the PPP.LOG file will be created. If you are running one of these two processes, you need to restart only that process.

If you look at the PPP.LOG file size while RAS is running, it may be zero bytes. This is by design. RAS continues to use the PPP.LOG therefore, the file size may not be updated properly. To update the file size while the PPP.LOG file is still in use, simply access the file in some way. For example, open the file in Notepad or use the TYPE command to echo the contents of the file to the console.

For additional instructions on how to use the Windows NT Registry Editor to enable the PPP.LOG file, please see the following article in the Microsoft Knowledge Base:

ARTICLE-ID: 115929
TITLE : Enabling PPP Logging in Windows NT


Modification Type:MajorLast Reviewed:5/7/2003
Keywords:kbnetwork KB136813