Problems Using Helix Hurricane with Windows 95/98 (136776)



The information in this article applies to:

  • Microsoft Windows 95
  • Microsoft Windows 98

This article was previously published under Q136776
If this article does not describe the error message that you are receiving, view the following Microsoft Knowledge Base article to view more articles that describe error messages:

315854 Windows 98 and Windows Me Error Message Resource Center

SYMPTOMS

The following problems may occur if you use Helix Hurricane with Windows:
  • When you use the RAM Doubler feature, you may receive the following error message when Windows starts: While initializing device ARPL: Windows protection error. You must restart your computer.
  • When you run the Hurricane Control Center (Hcc.exe), you may receive an error message on a blue screen similar to the following message: An exception xx has occurred at 0028:0000xxxx in VxD --- If you return to Windows by pressing ENTER, the Hurricane Control Center may run successfully.
  • After you enable the Hurricane Screen Accelerator, the Windows desktop may be inactive, or you may see a black screen with an active mouse pointer when Windows starts.
  • After you enable Hurricane WinGuard, you receive a Windows protection error.

CAUSE

Hurricane and its utilities are incompatible with Windows.

RESOLUTION

To resolve this problem, use any of the following methods:
  • Run the Hurricane uninstall tool. To do so, follow these steps:

    1. Start Windows in Safe mode. To do so, restart your computer, press the F8 key when you see the "Starting Windows 95" message, and then choose Safe Mode from the Startup menu.

      For Windows 98, restart your computer, press and hold down the CTRL key until you see the Windows 98 Startup menu, and then choose Safe Mode Command Prompt Only.
    2. Run the uninstall tool in the Hurricane folder.
  • If the uninstall tool is not available, follow these steps to disable Hurricane:

    1. Disable the following lines in the [386Enh] section of the System.ini file by placing a semicolon (;) at the beginning of each line:
             
               device=<path>arpl.386
               device=<path>Winsa.386
               device=<path>Winguard.386
               device=<path>vxmsems.386
               device=<path>windrv.386
               device=<path>vcache16.386
               device=<path>vsectd.386
               device=<path>heapx.386
            
      								
    2. Change the following lines in the [Boot] section of the System.ini file:
               From                             To
               --------------------------------------------------------
               system.drv=<path>sysdrv.drv      system.drv=System.drv
               display.drv=<path>winsa256.drv   display.drv=Pnpdrvr.drv
             
      								
      NOTE: If your original display driver was not Pnpdrvr.drv, start Windows in Safe mode and change the video driver.
    3. Restart your computer.
  • Upgrade to Helix Hurricane version 2.0 or later. For information about upgrading Helix Hurricane, please contact Helix.
If you continue to have problems, or for specific instructions about using the Hurricane uninstall tool, please contact Helix.

MORE INFORMATION

The third-party product discussed in this article is manufactured by a vendor independent of Microsoft; we make no warranty, implied or otherwise, regarding this product's performance or reliability.

Modification Type:MinorLast Reviewed:12/16/2004
Keywords:kb3rdparty kbAppCompatibility kberrmsg kbprb kbWinProtectErr KB136776