Updated Vserver.386 File for Windows for Workgroups (136418)



The information in this article applies to:

  • Microsoft Windows for Workgroups

This article was previously published under Q136418

SYMPTOMS

When you share a folder on a Windows for Workgroups 3.11-based computer, users on UNIX-based computers running the SMBCLIENT Samba network client who connect to the shared folder may have access to the entire drive on which the shared folder is located.

CAUSE

This problem can occur when all of the following conditions exist:

  • You use the Vserver.386 file included with Windows for Workgroups 3.11.
  • You use the TCP/IP network protocol.
  • There are UNIX-based computers on the network.

RESOLUTION

To resolve this problem in Windows for Workgroups 3.11, follow these steps:

  1. Download the Wfwvsrvr.exe file from one of the online services listed below to an empty directory.
  2. In File Manager, double-click the Wfwvsrvr.exe file to expand the Vserver.386 file it contains.
  3. Quit Windows for Workgroups.
  4. Copy the new Vserver.386 file to the Windows\System directory, overwriting the existing version of the file.
  5. Restart your computer.

MORE INFORMATION

The following file is available for download from the Microsoft Download Center:
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

Modification Type:MinorLast Reviewed:9/22/2005
Keywords:kbHotfixServer kbQFE kbdownload kb3rdPartyNetClient kbfile kbgraphxlinkcritical KB136418 kbAudDeveloper