XCLN: Err Msg: Windows Sockets Error: Failed in Connect (128961)



The information in this article applies to:

  • Microsoft Exchange Server 4.0

This article was previously published under Q128961

SYMPTOMS

The following error may occur when you use the Microsoft Exchange Internet Mail service:
Windows Sockets error
Failed in Connect

CAUSE

One of the following two events has occurred:
  • The TCP/IP software on the local computer is not installed or configured properly.

  • The other host is down.

RESOLUTION

  1. To check for proper installation and configuration, follow the steps below:
    1. In the Microsoft Windows 95 Control Panel, double-click the Network icon.
    2. Click the network interface adapter and click the Properties button.
    3. Click the Bindings tab and make sure TCP/IP is bound to the network adapter (Microsoft TCP/IP should be checked; if it is not checked, it is not bound to the network adapter.)
    4. Click the Cancel button.
    5. Click the TCP/IP line and click Properties.
    6. Check the IP address tab for your IP address and subnet mask, or DHCP.
    7. If you are not using DHCP, check the Gateway tab for a gateway IP address.
    8. Check the Bindings tab to ensure Client For Microsoft Networks is checked.
    9. On the Start menu, click Run.
    10. In the Open list box, type winipcfg.
    11. Click the Advanced button to verify the IP address, mask, and gateway.
    If you have not found the problem yet, simplify the configuration by removing any other protocols, additional network interface adapters, and server functionality.

    Restart and see if TCP/IP is working.

  2. To check the other host, perform the following steps:
    1. Go to an MS-DOS prompt.
    2. Type the following:

      ping <ip address of other host>

      If this command is not successful, contact the administrator of the other host to find out the status of the host. If it is successful, the other host is running.

    3. Go to a Telnet prompt.
    4. Connect to the other host, specifying port "smtp" or "25." If this is not successful, contact the administrator of the other host to find out the status of the host. If it is successful, the other host is running SMTP and is ready for messages.

Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbenv kbnetwork KB128961