Err Msg: The Device Has Been Disabled in Hardware... (Code 29) (128921)
The information in this article applies to:
This article was previously published under Q128921 SYMPTOMS
Device Manager displays an exclamation point in a yellow circle for a PCI
device. The status for this device reads:
The device has been disabled in the hardware. In order to use this
device, you must re-enable the hardware. See your hardware
documentation for details. (Code 29.)
CAUSE
This problem can occur for either of two reasons:
- Windows 95 knows the hardware will not function.
- The hardware is configured incorrectly.
Windows 95 Knows the Hardware Will Not Function
Read the README.TXT file in the Windows folder to see if there is a known
problem with the device. If the information in the README.TXT file does not
help you solve the problem, please contact the device's manufacturer for
additional instructions.
The Hardware Is Configured Incorrectly
The problem may be due to a configuration error in your computer's BIOS.
This can happen if the hardware is set to use resources that Windows 95
knows are not usable by the device. To verify that this is the problem,
check the I/O range for the device. If the I/O range starts at 0, Windows
95 cannot activate the hardware.
RESOLUTION
You may be able to resolve the problem by removing the device and
refreshing it on the PCI bus. This causes the PCI bus to be enumerated
again and lets Windows 95 reconfigure the hardware. To remove and refresh
a PCI device, follow these steps:
- Click the Start button, point to Settings, then click Control Panel.
- Double-click the System icon.
- Click the Device Manager tab, click the PCI device, then click the
Remove button.
NOTE: The software for this device is removed from the current
configuration for your computer.
- Click the View Devices By Connection option button and then click
PCI Bus.
- Click the Refresh button.
NOTE: The PCI device is detected, configured, and placed back in
the Device Manager.
Modification Type: | Major | Last Reviewed: | 12/17/2000 |
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Keywords: | KB128921 |
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