PROFS: VMGATE Log .MAI File Errors (128462)



The information in this article applies to:

  • Microsoft Mail Gateway to IBM PROFS and OfficeVision 3.4a

This article was previously published under Q128462

SYMPTOMS

The following errors occur in the VMGATE log:
[15:24] - ERROR: scanning data fields in: L:MAI\MAC\0001594C.MAI [15:24] -
...will try again at NEXT time, processing continues
[15:26] - ERROR: scanning data fields in: L:MAI\MAC\0001594C.MAI [15:26] -
...will try again at NEXT time, processing continues
[15:28] - ERROR: scanning data fields in: L:MAI\MAC\0001594C.MAI
[15:28] - ...SYSTEM.LOG entry written, diagnostic sent to:
After the .MAI file fails for the third time, the mail is returned to the sender and the following message is logged in the system log:
System log entry on: 12-15-94 15:28
VMGATE program has detected a mail problem
Message data:

From: IES/TOWER/SZHJZG
Date: 12-15-94
Time: 15:29
Subject: MMIS year end processing issues
Mail retry count exceeded sending to: VMGATE

CAUSE

The program was not reading data properly if a particular field was bigger than the buffer size, and started within the current buffered data.

STATUS

Microsoft has confirmed this to be a problem in version 3.4a of Microsoft Mail Gateway to PROFS. This problem was corrected in VMGATE.EXE version 3.40.0042. The following file is available for download from the Microsoft Download Center:
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

Modification Type:MinorLast Reviewed:8/9/2004
Keywords:kbdownload kbgraphxlinkcritical KB128462