MPRJ4: Error Type 1 or Hang Clicking Menu in Project (128331)



The information in this article applies to:

  • Microsoft Project for the Macintosh 4.0

This article was previously published under Q128331

SYMPTOMS

In Microsoft Project, when you click a menu, one of the following symptoms may occur:

  • You receive the following error message:
    The application "unknown" has unexpectedly quit, because an error of type 1 occurred.

    -or-

  • Microsoft Project may hang

CAUSE

This problem occurs if you add a menu item that contains more than 250 characters to a menu bar. When you apply the menu bar, and click the menu bar that contains the new menu item, you receive a type 1 error, or Microsoft Project hangs.

Note that this problem does not occur when you create a menu name or a menu description that contains 255 characters, the maximum number of characters that can be entered for any of the fields in the Menu Bar Definition dialog box.

WORKAROUND

To avoid this problem, create menu items that contain fewer than 250 characters. Because approximately the first 70 characters of a menu item are displayed on the screen, you may want to limit your menu item names to 70 characters. Note that you can include any additional information in the Description field for the item, which appears on the status bar when you select the menu item.

If you create a menu item that contains greater than 250 characters, and you click the menu that contains that menu item before you close Microsoft Project, the problem menu item is not saved to the Global Template file.

However, if you do not encounter this problem before you quit Microsoft Project, the menu item that causes the problem is saved to your Global Template file. To work around the problem in this case, you can reset the menu bar by doing the following:

  1. From the Tools menu, choose Customize, and then choose Menu Bars.
  2. From the Menu Bars list, select the menu bar that you modified, and choose Edit.
  3. In the Menu Bar Definition In Global Template dialog box, choose Reset.
  4. Choose Yes in the dialog box that appears asking if you want to set the menu bar back to its original settings.
  5. Choose OK. In the Menu Bars dialog box, choose Apply.

REFERENCES

For more information about Adding A New Menu To A Menu Bar (Cue Cards), choose the Search button in Help and type:

Menu Editor


Modification Type:MajorLast Reviewed:11/5/2000
Keywords:kbbug kberrmsg KB128331