Cannot access '<FILENAME.XLA>' Removing Add-In (128186)



The information in this article applies to:

  • Microsoft Excel 97 for Windows
  • Microsoft Excel for Windows 95
  • Microsoft Excel for Windows 5.0

This article was previously published under Q128186

SYMPTOMS

In Microsoft Excel, when you use the Add-Ins dialog box, you may receive the error message "Cannot access '<FILENAME.XLA>'" when you do one or both of the following:
  • Choose Add-Ins from the Tools menu. In this case, <FILENAME.XLA> is the filename of an add-in you created that is currently loaded.
  • Use the Add-Ins dialog box to remove an installed add-in. In this case, <FILENAME.XLA> is the filename of the add-in that you selected for removal from the Add-Ins dialog box.

CAUSE

This error message appears when you display the Add-Ins dialog box, and/or when you clear the check box next to an add-in in the Add-Ins dialog box. This problem may occur after you have installed an application that uses version 2.02 of STORAGE.DLL, such as the Microsoft Access version 2.0 Service Pack, or the Microsoft ODBC version 2.0 Driver Kit.

If you create an add-in and load it, this problem occurs when you open the Add-Ins dialog box after exiting and starting Microsoft Excel again. After you receive the error message, the add-in that corresponds to the file listed in the error message does not appear in the Add-Ins Available list in the Add-Ins dialog box. This problem only occurs with add-ins that you have created, not with add-ins that are installed by Microsoft Excel.

The error message only appears when you remove an add-in if you install and then remove an add-in in the same session of Microsoft Excel. If you install an add-in, and then exit Microsoft Excel, you do not receive this error message when you remove the add-in during a later session of Microsoft Excel. Additionally, when you choose Cancel for the error message that appears, the add-in is removed as expected.

RESOLUTION

Version 2.03 of the Storage.dll file corrects this problem. This .dll is available in the Application Note "OLE Version 2.03" (WW1116). For additional information, please see the following article(s) in the Microsoft Knowledge Base:

123087 WW1116: OLE Version 2.03

WORKAROUND

To work around this problem, use the appropriate procedure below:
  • If you receive this error message when you open the Add-Ins dialog box, the information necessary for loading the add-in is removed from the EXCEL5.INI file when you close Microsoft Excel. Steps 1-4 below are necessary in order for the add-in file to be referenced in the EXCEL5.INI file again.


    1. Close Microsoft Excel, and then start Microsoft Excel again.
    2. From the Tools menu, choose Add-Ins.
    3. In the list of Add-ins Available, select the check box next to any add-ins that you want to load, and choose OK.
  • If you receive this error message when you remove an add-in from the Add-Ins dialog box, use any of the following methods to work around this problem:

    Method 1: In the dialog box that contains the error message described above, choose Cancel. The add-in that you removed in the Add-Ins dialog box is removed as expected (even though you receive the error message).

    Method 2: To avoid receiving this error message, close Microsoft Excel before you remove an add-in that you installed during the current session of Microsoft Excel.

STATUS

Microsoft has confirmed this to be a problem with version 2.02 of STORAGE.DLL and the Microsoft products listed at the beginning of this article. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

MORE INFORMATION

NOTE: An additional symptom that occurs as a result of this problem is that the description that normally appears in the Add-Ins dialog box when you select an add-in may not appear. For example, when you select the ODBC add- in either to install or remove it, the following description appears in the Add-Ins dialog box:

Lets you use ODBC functions to connect to external data sources directly.

However, when you clear the ODBC Add-In check box after installing the add- in the same Microsoft Excel session, the description may not appear if version 2.02 of the STORAGE.DLL file is installed on your computer.

REFERENCES

For more information about Installing Or Removing An Add-In, choose the Search button in Help and type:

add-ins


Modification Type:MinorLast Reviewed:8/15/2005
Keywords:KB128186