PRB: Cannot Hear Bell in FoxPro for Windows (126405)
The information in this article applies to:
- Microsoft Visual FoxPro for Windows 3.0
This article was previously published under Q126405 SYMPTOMS
If you have installed multimedia software or a sound board, using CHR(7) to
ring the bell may no longer work in FoxPro. The bell is silent whether you
SET BELL TO a wave file, or to the normal system bell.
CAUSE
The multimedia software installed TIMER.DRV as a device driver in the
[DEVICE] section of the SYSTEM.INI file. TIMER.DRV is causing a conflict
with FoxPro and the bell is not ringing.
WORKAROUND
There are two possible resolutions to the problem:
- Remove TIMER.DRV by choosing the Control Panel Drivers icon,
highlighting the TIMER.DRV entry, and clicking the Remove push button.
- Use the steps outlined in the following article in the Microsoft
Knowledge Base:
102585 How to Play Waveform (.WAV) Files in FoxPro for Windows
This article explains how to use FOXTOOLS.FLL to call the Windows
multimedia API to play a sound file. This article will work regardless
of which multimedia driver is installed, or whether or not a sound
board is installed.
STATUS
This behavior is by design.
Modification Type: | Major | Last Reviewed: | 9/30/2003 |
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Keywords: | KB126405 |
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