Hotsite: HP Jet Direct (HPREDIR) Unable to Add Printer (115279)
The information in this article applies to:
- Microsoft LAN Manager 2.0
- Microsoft LAN Manager 2.1
- Microsoft LAN Manager 2.1a
- Microsoft LAN Manager 2.2
- Microsoft LAN Manager 2.2b
This article was previously published under Q115279 SYMPTOMS
If there are a lot of printers on a network, HP Jet Direct software
sometimes cannot display the list of available HP Laserjet network
attached printers. The first attempt to setup the printer appears to work,
but the list box actually is incomplete; all subsequent attempts produce
an empty list box.
CAUSE
HP Jet Direct [HPREDIR] allows LAN Manager to redirect printer queues to
network attached printers by means of DLC protocol [Comtokr]. When you
set up a new printer with HPREDIR it broadcasts a roll call command, to
which all HP printers respond, indicating their current status (in use,
versions, etc.). Comtokr buffers these responses and sends them to HPREDIR.
If there are many printers on the network, and Comtokr's buffers become
filled with responses, Comtokr sends all buffered roll call response frames
to HPREDIR, which displays addresses and statuses. Comtokr should continue
to buffer frames as it finds room, but it does not. After it fills its
buffer once, Comtokr stops forwarding roll call response frames to HPREDIR.
HPREDIR displays an empty printer selection list.
The problem occurs on all versions of HP Jet direct and Microsoft LAN
Manager.
WORKAROUND
Stopping and restarting HPREDIR on the server corrects the problem, but
it recurs immediately if you select Add Printer.
Even though the problem appears to be in Microsoft Comtokr code, HP has
devised a workaround that may help in certain situations by increasing the
number of printers that Comtokr can handle.
You can also reduce the number of printers on a broadcast subnet so that
not all the printers see the roll call frame.
Windows NT does not have this problem.
STATUS
Microsoft has confirmed this to be a problem in LAN Manager version 2.2.
We are researching this problem and will post new information here in the
Microsoft Knowledge Base as it becomes available.
Modification Type: | Minor | Last Reviewed: | 10/18/2005 |
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Keywords: | KB115279 |
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