Print Manager Hangs After Upgrading to Windows NT Server (114622)



The information in this article applies to:

  • Microsoft LAN Manager to Windows NT Advanced Server Upgrade
  • Microsoft Windows NT Server 3.1
  • Microsoft Windows NT Workstation 3.1

This article was previously published under Q114622

SYMPTOMS

If you have an HP printer shared on your LAN Manager 2.2 server and you upgrade to Windows NT Server by using the Windows NT Advanced Server Upgrade for LAN Manager, both Print Manager and Registry Editor may stop responding (hang) when started.

CAUSE

During the upgrade process, an invalid printer reference is made in the Registry.

WORKAROUND

  1. Run Registry Editor from a remote computer and select the new Windows NT server.
  2. Under the HKEY_LOCAL_MACHINE subtree, find the following key:

    \SYSTEM\CurrentControlSet\Control\Print\Printers
  3. Delete the HP printer reference.
  4. Exit Registry Editor and restart the Windows NT server.
  5. Run Print Manager on the Windows NT server and add the HP printer again.

STATUS

Microsoft has confirmed this to be a problem in Windows NT and Windows NT Advanced Server version 3.1. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

Modification Type:MinorLast Reviewed:8/16/2005
Keywords:kbprint KB114622