ACC: System Error When Sharing Database on LAN Man/Workgroups (100160)
The information in this article applies to:
- Microsoft Access 1.0
- Microsoft Access 1.1
- Microsoft Access 2.0
This article was previously published under Q100160 SYMPTOMS
Advanced: Requires expert coding, interoperability, and multiuser skills.
If you try to save a Microsoft Access database larger than 2000 bytes
(approximately 2 MB) on a Microsoft LAN Manager server with a boot
drive that uses the file allocation table (FAT) format, the following
error message appears:
System error... Network error on drive <x>
This error occurs only on Microsoft Windows for Workgroups
workstations if you attempt to open a database already in use by a
Microsoft LAN Manager workstation or another Windows for Workgroups
workstation.
CAUSE
The Microsoft LAN Manager server responds incorrectly to a request by
Windows for Workgroups to share the file. The server responds with a
message that is too long for Windows for Workgroups to process
correctly, resulting in an error from the NetBIOS.
RESOLUTION
The following are two ways to work around this behavior:
- Change the format of the Microsoft LAN Manager server boot drive
from FAT to high-performance file system (HPFS), then place the
Microsoft Access database you want to share on the boot drive.
-or-
- Move the database to a Windows for Workgroups server.
Modification Type: | Major | Last Reviewed: | 5/6/2003 |
---|
Keywords: | kbprb kbusage KB100160 |
---|
|